• Ten serwis używa "ciasteczek" (cookies). Korzystając z niego, wyrażasz zgodę na użycie plików cookies. Learn more.
  • Szanowny Użytkowniku, serwisy w domenie modelarstwo.info wykorzystują pliki cookie by ułatwić korzystanie z naszych serwisów. Jeśli nie chcesz, by pliki cookies były zapisywane na Twoim dysku zmień ustawienia swojej przeglądarki.

H0 Czy Piko żartuje?

jabol

Aktywny użytkownik
#1
Witam,

Mam mały problem z Piko ST44-613 (Piko 50805) z fabrycznym dekoderem. Nie używałem tej lokomotywy przez parę tygodni i jak ją „odpaliłem” parę dni temu to lokomotywa bardzo wolno jeździła w jednym kierunku. Zdecydowałem się na prosty reset dekodera (CV8=0) używając Roco Mulitmaus. Niestety po tym resecie kilka funkcji (czerwone światła i klika innych) nie działa. Wysłałem email do Piko i dostałem odpowiedź że muszę zaprogramować dekoder. Problem jest taki że Piko wysłało mi 23 stron kodów:) Wydaje mi się że prosty reset dekodera nie powinien powodować takich problemów - przynajmniej ja się nigdy z czymś takim nie spotkałem. Ciekawy jestem czy ktoś miał podobny problem.

Pozdrawiam.
 

przemas22223

Aktywny użytkownik
#2
Czy wybierasz się do Sosnowca? Jak daleko masz do tej miejscowości?
Na imprezie z makietami będzie człowiek, który zna się na tym. Jest nim Elvis.

Pozdrawiam
 

DrCodeWizzard

Aktywny użytkownik
#4
Według tej strony: https://dccwiki.com/Decoder_reset reset przez CV08 przywraca dekoder do wartości fabrycznych. W jaki sposób CV08 to robi i jakie są wartości fabryczne zależy od dekodera i nie jest w żaden sposób ze-standardyzowane. Wobec tego zakładam że do Polskich lokomotyw PIKO użyło normalnych dekoderów dostępnych na rynku i do obsługi Polskich świateł specjalnie zaprogramowało dekoder. W takim przypadku użycie CV08 spowodowało stratę ustawień na Polskę.
 

Ropu

Ostrzeżony
#5
Dekodery Piko Smartcośtam to narazie niedopracowany produkt - lub źle opracowany.
Wg instrukcji jest jeszcze CV59, którym można zresetować tylko pewne zakresy CV - ale chyba brak wyjaśnienia w którym zakresie znajduje się konfiguracja świateł itd.
Poza tym co to oznacza ustawienia fabryczne - u innych producentów to standardowe ustawienia dekodera dla danej lokomotywy. W Piko to gołe ustawienia standardowe od Uhlenbrocka - przecież to bez sensu...
 
Ostatnio edytowane:

CoCu

Znany użytkownik
#7
Upatruję tu dwa problemy.

1.
Większość osób przywykła do dotychczas szeroko stosowanych dekoderów w swojej najprostszej postaci, czyli bez ustawionego niemal czegokolwiek, dających tylko jazdę do przodu/tyłu oraz włączenie świateł białych z jednej strony, a czerwonych z drugiej. To można nazwać "standardowymi ustawieniami dekoderów", bo to potrafi każdy zaraz po wsadzeniu do modelu. Ale w sumie od wielu lat, elektronika pozwala na wiele więcej, również od dawna produkowane dekodery. Producenci modeli jednak jakby mało kiedy korzystali z tego, wypuszczając na rynek modele często jedynie z tymi powyżej przeze mnie opisanymi "standardowymi ustawieniami", mającymi się nijak do symulowania pracy prawdziwej lokomotywy.
Jeśli chcemy by model wyświetlał nam wiele czy też wszystkie stosowane na PKP sygnały świetlne, konieczne jest odpowiednie ustawienie bardzo wielu zmiennych CV. Do tego nie tylko trzeba zaprogramować, by dany klawisz włączał daną rzecz, ale jeszcze zależności między sobą pomiędzy poszczególnymi sygnałami, oraz kierunkiem jazdy. To kolejnych wiele zmiennych CV do zaprogramowania. Plus do tego jeszcze mogą dojść dźwięki...
I teraz zależy, czy reset dekodera oznacza powrót do tych jedynie "standardowych ustawień", a przez to przy okazji wprowadza taką zmianę w ogromie zmiennych CV że tracimy te wszystkie zaprogramowane funkcje, czy też oznacza powrót do tych wszystkich już ustawionych odpowiednio CV, na przykład w przypadku gdy coś w nich źle ustawimy. Jeśli to pierwsze, to efekt jest jak powyżej kolega opisał - byłoby trzeba wszystko ustawiać teraz od nowa. Jeśli to drugie, nie tracimy nic, znaczy tylko to co sami ewentualnie zmieniliśmy. Oczywiście reset z pierwszego przykładu jest bardzo niemiły dla użytkownika a i przecież nigdzie nikt nie napisał że stracimy wszystko.

Jako ciekawostkę dodam, że pierwszym modelem seryjnym do jakiego można było kupić dekoder już ustawiony pod światła PKP, był model EU07 firmy Schlesienmodelle. Wtedy też wielu klientów przeżyło wielki szok, gdy się zorientowali, że w tych dekoderach jest ustawiony taki ogrom CV, że mało kto jest w stanie to ogarnąć. Obecnie tak zaprogramowane dekodery już przestają dziwić, bo jeśli chcemy mieć światła PKP a tym samym wykorzystać możliwości dzisiejszej elektroniki, w tym dekoderów, to nie wystarczy zmienić dwóch czy trzech CV.

2.
Zauważyć można, iż wiele osób jak tylko coś się dziele źle z modelem cyfrowym z miejsca decyduje się na reset dekodera, nawet jeśli nigdy w nim nic nie zmieniano. Do tego na forum jak tylko ktoś napisze że mu model cyfrowy źle działa, to z miejsca ktoś "mądry" pisze by zresetować dekoder. Ciekawe jednak, że większość osób z problemami, końcowo stwierdza że reset nic nie dał... Albo jest jeszcze gorzej, jak w przypadku powyżej.
 

DRACULA

Aktywny użytkownik
#9
Kupuję model z dekoderem tzw "dźwiękowym" czyli z licznymi funkcjami .
W przypadku polskich lokomotyw także z polskimi sygnałami świetlnymi . ( naprawdę straszna filozofia ! że raz świecą się te światełka a raz inne - śmiech na sali :D )
Wszystko działa ! Jak w szwajcarskim zegarku ...

Mam możliwość sensownych zmian w funkcjach np. głośności poszczególnych "dźwięków", siły świateł.
Zgodnie z instrukcją zwiększam lub zmniejszam "wartość" w odpowiednim JEDNYM dla danej funkcji CV .
To wszystko !
Reset to ustawienia fabryczne a nie skasowanie wszystkiego.


To co sprzedaje Piko jako dekodery dźwiękowe to niedopracowane elektroniczne śmiecie wypchnięte butami na rynek ...
Tak to widzę .
 
Ostatnio edytowane:

Andrzej Harassek

Moderator For Prawdziwa Kolej Koleje Innych Krajów
Zespół forum
Donator forum
#12
Zdecydowałem się na prosty reset dekodera (CV8=0) używając Roco Mulitmaus. Niestety po tym resecie kilka funkcji (czerwone światła i klika innych) nie działa. Wysłałem email do Piko i dostałem odpowiedź że muszę zaprogramować dekoder. ...... Wydaje mi się że prosty reset dekodera nie powinien powodować takich problemów - przynajmniej ja się nigdy z czymś takim nie spotkałem.
To jest moim zdaniem zupełnie normalne i dziwię się, że kolega jabol nigdy się z tym nie spotkał - może nigdy nie miał potrzeby resetowania dekodera. Rację ma kolega DrCodeWizzard:
reset przez CV08 przywraca dekoder do wartości fabrycznych. W jaki sposób CV08 to robi i jakie są wartości fabryczne zależy od dekodera
Pytanie, co to są "wartości fabryczne"? W wypadku dekodera kupionego osobno, to oczywiście podstawowe funkcje i wartości CV zgodnie z opisem w instrukcji dekodera - zawsze są podane fabryczne (domyślne) wartości CV. Jeżeli ktoś po kupnie zmieni te wartości, zmieniając np. mapowanie funkcji, jasność świateł, rodzaj efektów świetlnych (np. miganie) itp. to oczywiście przy resecie do wartości fabrycznych wszystkie te zmiany znikną. Pytanie teraz, czy 1) Piko sprzedając model z dekoderem samo zmodyfikowało ustawienia, czy też 2) producent dekodera wyprodukował dla Piko specjalną wersję dekodera, w której te specyficzne ustawienia są uważane za fabryczne? Z doświadczeń kolegi jabola wynika, że występuje ta pierwsza sytuacja, co też przypuszcza kolega DrCodeWizzard:
Wobec tego zakładam że do Polskich lokomotyw PIKO użyło normalnych dekoderów dostępnych na rynku i do obsługi Polskich świateł specjalnie zaprogramowało dekoder. W takim przypadku użycie CV08 spowodowało stratę ustawień na Polskę.
elektronika pozwala na wiele więcej, również od dawna produkowane dekodery. Producenci modeli jednak jakby mało kiedy korzystali z tego, wypuszczając na rynek modele często jedynie z tymi powyżej przeze mnie opisanymi "standardowymi ustawieniami", mającymi się nijak do symulowania pracy prawdziwej lokomotywy.
Przede wszystkim do niedawna większość modeli nie miała instalacji elektrycznej umożliwiającej wyświetlanie różnych świateł, nie było nawet możliwości wyłączenia tylnych czerwonych świateł. Teraz coraz więcej modeli ma już taką możliwość, a często również da się wyświetlić różne inne sygnały. Ale do tego potrzeba odpowiednio skonfigurowanego dekodera. I tu wracamy do opisanego wyżej problemu.
I teraz zależy, czy reset dekodera oznacza powrót do tych jedynie "standardowych ustawień", a przez to przy okazji wprowadza taką zmianę w ogromie zmiennych CV że tracimy te wszystkie zaprogramowane funkcje, czy też oznacza powrót do tych wszystkich już ustawionych odpowiednio CV, na przykład w przypadku gdy coś w nich źle ustawimy.
Z mojej (niewielkiej) wiedzy wynika, że nie ma możliwości, by reset (CV8=8) spowodował cofnięcie tylko ostatnio zmienionych ustawień, pozostawiając zmiany wprowadzone wcześniej, ale już po wyjściu dekodera od producenta.
Oczywiście reset z pierwszego przykładu jest bardzo niemiły dla użytkownika a i przecież nigdzie nikt nie napisał że stracimy wszystko.
Jest niemiły, ale przecież wszędzie podaje się, że reset oznacza powrót do wartości fabrycznych, co znaczy, że tracimy wszystkie zmiany wprowadzone po wyjściu dekodera z fabryki - to powinno być jasne dla wszystkich, którzy próbują cokolwiek zmieniać w ustawieniach.
 

Ropu

Ostrzeżony
#13
Myślę, że nie Panie Andrzeju - nie podam teraz na szybko przykładu, bo dość rzadko musiałem resetować dekodery fabryczne - fabrycznie wbudowane w lokomotywę - ale nigdy nie traciłem ustawień oświetlenia, dźwięków itd. To że kolega ma problem z oświwtleniem po resecie, a nie ma z dźwiękami, które dalej są na swoich eFkach też świadczy jednak o wybiórczym zresetowaniu dekodera.
Pozdrawiam serdecznie
 

Andrzej Harassek

Moderator For Prawdziwa Kolej Koleje Innych Krajów
Zespół forum
Donator forum
#14
Wręcz przeciwnie, to mnie właśnie utwierdza w przekonaniu, że mam rację. Dekoder fabrycznie ma ustawienia pozwalające na sterowanie dźwiękami i podstawowymi światłami. Ale jeżeli ustawienia CV sterujących światłami (ale tylko światłami, ustawienia dźwięków bez zmian) zostaną zmienione (np. do polskich sygnałów), to po resecie te ustawienia znikną. A jeżeli model ma obwody świateł zrobione tak, że wymagają zmian ustawień do świateł, to po resecie świateł nie będzie w ogóle. Dekoder wróci do podstawowych ustawień świateł, ale obwody świateł modelu wymagają innych ustawień żeby w ogóle świeciły.
 

Ropu

Ostrzeżony
#15
A skad zalozenie, ze ustawienia dekodera pozwalające na sterowanie dźwiękami sa zawsze takie same i od zawsze zaimplementowane?
Surowy dekoder dzwieku ESU przykładowo nie ma wgranych żadnych dźwięków - wiec i brak konfiguracji w poszczególnych CV, który soundslot będzie przypisany do którego F - już o innych jego parametrach nie wspominając.
A jeżeli model ma obwody świateł zrobione tak, że wymagają zmian ustawień do świateł, to po resecie świateł nie będzie w ogóle. Dekoder wróci do podstawowych ustawień świateł, ale obwody świateł modelu wymagają innych ustawień żeby w ogóle świeciły.
Technicznie tak to właśnie sie dzieje w "naszym" przypadku - moje zaskoczenie budzi tylko fakt, ze dekoder, który w nazwie ma PIKO i jest wbudowany fabrycznie do lokomotywy PIKO nie ma zapisanego punktu przywracania ustawień do stanu w jakim jest sprzedawany, tylko w stanie zupełnie innym. Reset do ustawień fabrycznych powinien przywracać ustawienia dekodera do stanu po wyjęciu lokomotywy z pudelka.
 

Andrzej Harassek

Moderator For Prawdziwa Kolej Koleje Innych Krajów
Zespół forum
Donator forum
#16
Surowy dekoder dzwieku ESU przykładowo nie ma wgranych żadnych dźwięków - wiec i brak konfiguracji w poszczególnych CV, który soundslot będzie przypisany do którego F
No nie całkiem. Jeżeli do "surowego" ESU LokSound wgra się projekt dźwiękowy, to bez zmiany CV dźwięki działają standardowo: F1 to włączanie/wyłączanie, dalej chyba F 2 to gwizdawka (syrena) itd. - z pamięci nie powiem. Reset nie "wyrzuca" projektu dźwiękowego. Światła działają tylko z F 0 - włącz/wyłącz, bez oddzielnego wyłączania czerwonych i bez żadnych innych efektów. Do polskich świateł trzeba pozmieniać mapowanie F sterujących światłami, a konkretnie przypisać funkcje świateł do wolnych F. Nie ma potrzeby zmiany CV odpowiadających za sterowanie dźwiękami, więc jeżeli nic nie zmieniono, to po resecie dalej dźwięki działają - ale światła już niekoniecznie. I tu się zgadzamy, moim zdaniem tak właśnie jest:
Technicznie tak to właśnie sie dzieje w "naszym" przypadku - moje zaskoczenie budzi tylko fakt, ze dekoder, który w nazwie ma PIKO i jest wbudowany fabrycznie do lokomotywy PIKO nie ma zapisanego punktu przywracania ustawień do stanu w jakim jest sprzedawany, tylko w stanie zupełnie innym. Reset do ustawień fabrycznych powinien przywracać ustawienia dekodera do stanu po wyjęciu lokomotywy z pudelka.
Ja też jestem tym zdziwiony, ale to już inna sprawa.
 

Ropu

Ostrzeżony
#17
Zawsze mi sie wydawalo, ze projekt dźwiękowy to nie tylko same pliki dźwiękowe, które dekoder poprzez swoja prekonfigurację wie jak poustawiać na eFkach - moim zdaniem projekt dźwiękowy to dźwięki ORAZ konfiguracja jak maja sie odnaleźć na centralce itd.
Ale przyznaje - nie jestem pewien - i nie mam niestety czasu, zeby to przestudiować i porownac parametry CV surowego dekodera i dekodera z już wgranym dzwiekiem.
Może fachowcy podpowiedzą?
 

Andrzej Harassek

Moderator For Prawdziwa Kolej Koleje Innych Krajów
Zespół forum
Donator forum
#18
Na 100% nie powiem, ale wydaje mi się, że dekoder fabrycznie wie, jak obsłużyć projekt dźwiękowy - przynajmniej dekodery ESU wiedzą jak obsłużyć projekty dźwiękowe, które można pobrać ze strony ESU. Czy inne projekty wymagają zmian, czy też wykorzystują fabryczne ustawienia, tego nie wiem. Ale też jestem ciekaw zdania fachowców.
 
#19
Technicznie tak to właśnie sie dzieje w "naszym" przypadku - moje zaskoczenie budzi tylko fakt, ze dekoder, który w nazwie ma PIKO i jest wbudowany fabrycznie do lokomotywy PIKO nie ma zapisanego punktu przywracania ustawień do stanu w jakim jest sprzedawany, tylko w stanie zupełnie innym. Reset do ustawień fabrycznych powinien przywracać ustawienia dekodera do stanu po wyjęciu lokomotywy z pudelka.
Koledzy podejrzewam że Piko modernizuje te dekodery bez wiedzy producenta .
Po drugie podejrzewam że dzieje się tak dlatego że producent narzucił w tym przypadku firmie Piko że jak zamówią konkretną ilość dekoderów (pewnie była to jakaś absurdalna ilość) to oni zrobią to tak jak ma być pod ustawienia danego kraju i reset będzie wracał do ustawień konkretnego kraju/ modelu loka
Pozdro Tomek
Ps. nie jestem agentem Piko żeby to było jasne:cool::D
 

Andrzej Harassek

Moderator For Prawdziwa Kolej Koleje Innych Krajów
Zespół forum
Donator forum
#20
Może niekoniecznie bez wiedzy producenta, ale pewnie robią to sami, już po otrzymaniu dekoderów od ich producenta. Ale może też być i tak, że to producent dekoderów robi te modyfikacje, ale albo nie chce się mu poprawiać całego systemu (żeby reset przywracał ustawienia po modyfikacji "krajowej"), albo oprogramowanie dekodera nie daje takiej możliwości bez całkowitej zmiany (przeprojektowania) całego "systemu operacyjnego" dekodera. Ale zaczynamy już wchodzić w daleko idące spekulacje...
 

Podobne wątki